Weinblog, Reiseblog & Digitalisierung

Excel Wenn-Funktion mit Textausgabe

Wie kann man mit Excel Wenn-Dann-Abfragen einrichten, die als Ergebnis verschiedene Texte ausgeben?

Nähern wir uns diesem Problem mit einer sehr einfachen Rentabilitätsrechnung für die BahnCard 25 und BahnCard 50. In der Tabelle sind verschiedene Fahrten zu Normalpreis und den jeweils ermäßigten Preisen aufgeführt.

Erklärung zur Tabelle
Unterhalb der einzelnen Fahrten werden in der jeweiligen Spalte Summen gebildet: "=SUMME(D15:D28)" addiert hier die Zellen D15 bis D28.

Unterhalb den Summen werden die Differenzen zwischen Normalpreis und BahnCard-Preis errechnet, z. B. "=D29-E29".

In der Zeile "Einsparung" wird die Differenz der Einsparung im Verhältnis zum Anschaffungspreis der BahnCards ermittelt, z. B. "=E31-E30". Dies ergibt in unserem Beispiel für die BahnCard 25: 115,38 € - 57 € = -58,38 €. Hier hat sie die BahnCard 25 also bereits zu 58,38 € gelohnt.

<center></center>

Kenntlichmachung, ab wann sich welche BahnCard lohnt: Bedingte Formatierung
Ein Weg, wie man die Ergebnisse unserer Zeile "Einsparung" kenntlich machen kann, ist die bedingte Formatierung. Hierzu wählen wir die Zellen E32 und F32 aus und wählen im Menü "Format -> Bedingte Formatierung". Im Dialogfenster nehmen wir die in der Abbildung gezeigten Einstellungen vor. Gemäß dieser Einstellungen wird der Text dieser beiden Zellen grün, wenn er im negativen Bereich ist und rot, wenn er im positiven Bereich ist, hier eine BahnCard also unrentabel wäre.

<center></center>

<center>Beispiel:

</center>

Kenntlichmachung, ab wann sich welche BahnCard lohnt: Textausgabe mit WENN-Abfrage
Anschaulicher wird es, wenn es Text ausgegeben wird, der sofort verrät, ob sich mit den in der Tabelle eingetragenen Fahrten die BanCard 25 oder die BahnCard 50 lohnt anzuschaffen. Mann kann also eine Abfrage schreiben, die skiziert dies prüfen soll: "Gib mir einen Text aus, der verrät, ob sie die BanCard 50, die BahnCard 25 oder gar keine BahnCard mit den eingegebenen Fahrten lohnt."

In der Zelle, in welcher die Textaussagen stehen sollen, ist dieser Code einzugeben:
"=WENN(F32<0;"Mit den angegebenen Fahrten ist die Bahncard 50 rentabel.";WENN(E32<=0;"Mit den angegebenen Fahrten, ist die BahnCard 25 rentabel.";"Keine BahnCard ist rentabel!"))"

<center>Veranschaulicht:

</center>

Hier gibt es, wie so oft, viele Wege, die zum gewünschten Ergebnis führen. Weiterführendes und Rat lässt sich in einschlägigen Fachforen finden, hier wird nur ein Codebeispiel gezeigt, an welchem man sich entlanghangeln kann.

Stay blogged. 8-)

Euer Matthias

Kommentare